Error: Could not find gradle wrapper within Android SDK. Might need to update your Android SDK.

Published on Author Code Father

Error: Could not find gradle wrapper within Android SDK. Might need to update your Android SDK. It may be an occlusion in the instructions regarding how to install (or upgrade) Android Studio with all the SDK Tools which both you and I missed or possibly a bug created by a new release of Studio which does not follow the same file conventions as the older versions. I lean towards the latter since many of the SO posts on this topic seems to point to an ANDROID_PATH with a folder called android-sdk which does not appear in the latest (2.3.0.8) version. There appears to be a workaround though, which I just got to work on my machine. Here’s what I did:

  • Download tools_r25.2.3-windows.zip from Android Downloads.
  • Extracted zip on desktop
  • Replaced C:\Users\username\AppData\Local\Android\sdk\tools with extracted sub-folder tools/
  • In project folder: $ cordova platforms remove android $ cordova platforms add android

You may also need to force remove the node_modules in android. Hopefully this helps.

Comments

comments