Use Legacy Swift Language Version error in Xcode 8.2

Published on Author Code Father
Use Legacy Swift Language Version error in Xcode 8.2

Found work around. I went through each target (and project settings, so both in the project and target) in my project, toggled the “Use Legacy Swift Language Version” from “No” to “Yes” and back to “No” for each. The project then built again.

enter image description here

———————-/OR/———————

Close Xcode and open the corresponding project.pbxproj in a text editor of your choice.

Replace SWIFT_VERSION = 3.0.1; with SWIFT_VERSION = 3.0; for all targets.

Reopen Xcode.

Comments

comments

Categories IOS